Bugsp.ru

Ваша компьютерная помощь
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как убрать округление чисел в Excel

Округление чисел в Microsoft Excel

Редактор таблиц Microsoft Excel широко применяется для выполнения разного рода вычислений. В зависимости от того, какая именно задача стоит перед пользователем, меняются как условия выполнения задачи, так и требования к получаемому результату. Как известно, выполняя расчёты, очень часто в результате получаются дробные, нецелые значения, что в одних случаях хорошо, а в других, наоборот, неудобно. В этой статье подробно рассмотрим, как округлить или убрать округление чисел в Excel. Давайте разбираться. Поехали!

Округление чисел в Microsoft Excel

Для удаления дробных значений применяют специальные формулы

О существовании специальной функции округления в Экселе знают далеко не все пользователи. Случается, что некоторые из них ошибочно принимают формат значений, то есть отображаемое количество знаков после запятой, за округление. Далее в статье разберёмся, что к чему и как всё делается.

Для начала отметим, что функция «Формат числа» применяется в случаях, когда вид числа необходимо сделать более удобным для чтения. Кликните правой кнопкой мыши и выберите в списке пункт «Формат ячеек». На вкладке «Числовой» установите количество видимых знаков в соответствующем поле.

Настройка количества видимых знаков

Но в Excel реализована отдельная функция, позволяющая выполнять настоящее округление по математическим правилам. Для этого вам понадобится поработать с полем для формул. Например, вам нужно округлить значение, содержащееся в ячейке с адресом A2 так, чтобы после запятой остался только один знак. В таком случае функция будет иметь такой вид (без кавычек): «=ОКРУГЛ(A2;1)».

Выбор математической формулы

Принцип прост и понятен. Вместо адреса ячейки вы можете сразу указать само число. Бывают случаи, когда возникает необходимость округлить до тысяч, миллионов и больше. Например, если нужно сделать из 233123 — 233000. Как же быть в таком случае? Принцип тут такой же, как было описано выше, с той разницей, что цифру, отвечающую за количество разделов, которые необходимо округлить, нужно написать со знаком «-» (минус). Выглядит это так: «=ОКРУГЛ(233123;-3)». В результате вы получите число 233000.

Выбор диапазона и разрядности

Если требуется округлить число в меньшую либо в большую сторону (без учёта того, к какой стороне ближе), то воспользуйтесь функциями «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ». Вызовите окно «Вставка функции». В пункте «Категория» выберите «Математические» и в списке ниже вы найдёте «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».

Ещё в Excel реализована очень полезная функция «ОКРУГЛТ». Её идея в том, что она позволяет выполнить округление до требуемого разряда и кратности. Принцип такой же, как и в предыдущих случаях, только вместо количества разделов указывается цифра, на которую будет заканчиваться полученное число.

В последних версиях программы реализованы функции «ОКРВВЕРХ.МАТ» и «ОКРВНИЗ.МАТ». Они могут пригодиться, если нужно принудительно выполнить округление в какую-либо сторону с указанной точностью.

Читайте так же:
Как восстановить аккумулятор ноутбука

Принудительное округление с заданой точностью

Как вариант, решить проблему можно при помощи функции «ЦЕЛОЕ», принцип которой заключается в том, что дробная часть просто отбрасывается, округляя вниз.

Иногда программа автоматически округляет полученные значения. Отключить это не получится, но исправить ситуацию можно при помощи кнопки «Увеличить разрядность». Кликайте по ней, пока значение не приобретёт нужный вам вид.

Увеличение разрядности чисел

Теперь, когда вы разбираетесь, как выполнять округление числа, вам будет проще выполнять ряд задач в программе. Кроме того, эти навыки помогут вам и в решении повседневных вопросов, связанных с расчётами.

Если Excel округляет длинные числа

Если вы вставите в числовую ячейку длинное число с более, чем 15 разрядов, то Excel округлит его и выдаст нечто совсем непригодное. Например, число 893800399000003570 он покажет в виде 8,938E+17, а если по нему кликнуть, покажет его, как 893800399000003000. Здесь мы видим потерю последних трёх разрядов, что совершенно неприемлемо.

Решить проблему можно, если изменить формат ячейки или колонки с числового на текстовый. Тогда вставляемое число любой разрядности не будет преобразовываться. Также можно вставить его в числовую ячейку, если перед числом использовать знак одинарных кавычек.

Если Excel округляет длинные числа

Однако при преобразовании таких строчных записей в число Excel снова округляет все разряды больше 15-ти. Поэтому такой способ подходит лишь для представления больших чисел в таблице, а для вычислений они всё равно должны преобразовываться с потерями. Сделать с этим ничего нельзя – Excel так устроен, и 15 разрядов – предельная его точность, с которой можно записывать числа в таблице.

Пишите в комментариях были ли статья полезной для вас и продолжайте совершенствовать навыки работы в Microsoft Excel.

Как убрать округление чисел в Excel

Некоторые числа с одним или более десятичных знаками могут округляться на вашем компьютере. Если это не результат применения функции округлинга, это может произойти, если ширины столбца недостаточно для всего числа. Кроме того, это может произойти, если в формате замеряется меньшее количество десятичных десятичных знаков, чем содержит фактическое число.

Например, если ввести число в ячейку с общим форматированием (по умолчанию для всех ячеек на новом сайте), Excel автоматически отобразит меньше десятичных десятичных знаков, чтобы число умещается в ширину пустой ячейки. Число в ячейке A1 ниже округлится, но все оно по-прежнему отображается в панели формул в верхней части таблицы и используется в вычислениях.

Округленное число в ячейке A1 и неокругленное число в строке формул

Чтобы остановить округляние числа в ячейке, нажимайте кнопку Увеличить десятичность на вкладке Главная, пока не достигнете нужного количества десятичных десятичных заметок.

Читайте так же:
Как правильно выбрать карту памяти для смартфона

Кнопка "Увеличить разрядность" на вкладке "Главная"

При увеличении количества десятичных знаков формат изменяется с Общий на Число, а ширина столбца настраивается автоматически.

Примечание: Если ширина столбца не изменится и в ячейке появится #######, измените ширину столбца и высоту строки, дважды щелкнув правую границу его заглавного колонок.

Одновременное увеличение количества десятичных замеров для большого количества чисел

Если у вас много округляющихся чисел или они вообще не будут отображаться как округляющиеся, можно увеличить число десятичных десятичных заметок в числовом формате, а затем применить его к числам на вашем компьютере.

На вкладке Главная щелкните Кнопка диалогового окнарядом с кнопкой Число.

Кнопка диалогового окна в группе "Число" на вкладке "Главная"

В списке Категория выберите нужный числовом формате, убедившись в том, что он имеет десятичных разрядов, например Число,Валюта,Бухгалтерский, Процентный или Научных.

В поле Число десятичных знаков введите количество десятичных десятичных полей и нажмите кнопку ОК.

Одновременное увеличение количества десятичных замеров для большого количества чисел

Если у вас много округляющихся чисел или они вообще не будут отображаться как округляющиеся, можно увеличить число десятичных десятичных заметок в числовом формате, а затем применить его к числам на вашем компьютере.

На вкладке Главная в группе Число щелкните в > числовом формате.

В списке Категория выберите нужный числовом формате, убедившись в том, что он имеет десятичных разрядов, например Число,Валюта,Бухгалтерский, Процентный или Научных.

В поле Число десятичных знаков введите количество десятичных десятичных полей и нажмите кнопку ОК.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Как сделать, чтобы Эксель не округлял числа, когда не надо

screenshot 2021-10-04 058

Как сделать, чтобы Эксель не округлял числа? Воспользуйтесь функцией увеличения разрядности, используйте настройку или изменение формата ячеек. Выберите подходящую секцию, войдите в раздел «Число», и жмите на кнопку «Увеличить разрядность». После контролируйте изменения и учтите, что после выключения округления каждый последующий знак будет ноль. Ниже рассмотрим, как сделать, чтобы Эксель не округлял числа, и каким образом можно на место вернуть настройки.

Как отключить округление в Эксель

В процессе пользования Эксель часто возникает ситуации, когда при вводе данных цифры округляются. Это может влиять на точность расчеты и визуальное восприятие информации. В таком случае выделяется несколько вариантов, как сделать, чтобы Excel не округлял числа. Рассмотрим основные решения.

Увеличение разрядности

Наиболее простой метод выключения — применение опции увеличения разрядности, которая работает по принципу добавления чисел после запятой. Для решения задачи сделайте следующие шаги:

  • Определитесь, в какой ячейке не нужно округлять числа в Excel.
  • В разделе «Число» разверните список форматов и примите решение, какой хотите использовать.
Читайте так же:
Решение ошибки 0x000000d1 в Windows 7

  • Кликните по кнопке «Увеличить разрядность» в Эксель нужное число раз.

  • Контролируйте правки путем просмотра состояния секции и учтите, что после установки нужной функции округление выключиться. При добавлении нового знака будет «0».

В более новых версиях Excel этот метод будет иметь другой вид:

  1. Зайдите на кладку «Главная».
  2. Жмите на символ стрелки вниз справа от надписи «Число».
  3. В разделе «Категория» выберите нужный числовой вариант и убедитесь, что он имеет десятичные разряды.
  4. Найдите поле «Число десятичных» и введите нужную цифру, а после жмите «ОК».

Настройка формата

Еще один способ сделать так, чтобы Эксель не округлял — настроить формат и установить точное количество знаков после запятой. В настройках можно с легкостью увеличить цифру до требуемого, выключив округление. Для этого потребуется специальное меню в программе:

  • Выделите место в таблице, где нужно внести соответствующие изменения.
  • Разверните меню «Ячейки» и кликните на «Формат».

  • Выберите «Формат …».
  • Выделите с помощью левой кнопкой мышки ту цифру, которая применяется для выделенных ранее секций.
  • Установите количество знаков, вписав его в отведенное поле, используйте новые настройки и покиньте меню.

  • Посмотрите на выделенные ячейки и убедитесь в правильности отображения.

Изменение формата

Чтобы в Экселе не округлять числа, можно изменить формат. Этот вариант наиболее привлекательный в ситуации, когда в ячейке не хватает места для установки всех знаков. Можно использовать рассмотренный выше метод и поменять формат, но результат будет виден только после выхода из меню. Лучше войти в раздел «Число», как отмечалось в первом способе, и посмотреть представление цифр для других форматов. Выберите тот, который вам подходит, и сразу оцените изменения.

Как сделать, чтобы данные в таблице Эксель округлялись

Рассмотренные выше шаги позволяют сделать, чтоб Эксель не округлял числа. Но бывают ситуации, когда выполнение такого шага является обязательным для пользователя. В таком случае нужно снова включить опцию одним из доступных способов. Ниже рассмотрим наиболее востребованные варианты.

Кнопки в ленте

Наиболее простой метод, как сделать, чтобы Excel снова округлял, выделить одну / несколько ячеек, а после пройти такие шаги:

  1. Войдите в «Главная».
  2. Жмите на ленте кнопку «Увеличить / уменьшить разрядность». В первом случае количество знаков увеличивается, а во втором уменьшается на одну цифру.

Округление через форматирование

Выше мы разобрали, как не округлять в Экселе с помощью форматирования. Этот же метод можно использовать для включения опции. Сделайте следующие шаги:

  • Выделите диапазон ячеек на листе, жмите правой кнопкой мышки и кликните «Формат …».
Читайте так же:
Как отключить брандмауэр в Windows 8

  • Перейдите в раздел «Число». Если выбран не числовой вариант, выберите его. В ином случае сделать так, чтобы Эксель округлял, не получится.
  • В «Число десятичных знаков» внесите нужные данные.

Задание точности расчетов

Рассмотренные выше методы в Эксель оказывают влияние только на внешнее отображение в Эксель, а при расчетах использовались только точные показатели (до 15-ти знаков). При необходимости можно поменять точность вычислений. Сделайте следующее:

  • Войдите в «Файл», а далее «Параметры».

  • Найдите «Дополнительно», отыщите блок настроек «При пересчете этой книги».
  • Поставьте отметку возле параметра «Задать точность как на экране».

  • Жмите «ОК».

После выполнения этой задачи система будет округлять величину и использовать ее для вычислений.

Изменение функции

Для изменения размера округления при расчете одной, двух или более ячеек без уменьшения точности расчетов нужно использовать функцию округления «ОКРУГЛ» и разные ее варианты. К наиболее популярным относится «ОКРУГЛ» или округление до указанного числа десятичных знаков, «ОКРУГЛВВЕРХ» — до ближайшего верхнего, а «ОКРУГЛВНИЗ» — до ближайшего нижнего. Также можно сделать, чтобы Эксель округлял с заданной точностью с помощью «ОКРУГЛТ», или до ближайшего четного / нечетного параметра — «ЧЕТН», «НЕЧЕТН». Интересующую функцию можно вводить как в ячейку, так и в строку.

Дополнительный метод

Можно выделить еще один метод, как сделать, чтобы Excel округлял числа. Он подходит для случаев, когда в таблице находятся параметры, требующие преобразования. Сделайте следующие шаги:

  • Войдите во вкладку «Формулы».
  • Жмите на «Математические».
  • В появившемся списке выберите «ОКРУГЛ».
  • В окне аргументов в поле «Число» введите вручную нужный параметр.
  • Жмите по ячейке, где нужно, чтобы Эксель округлял цифры.
  • Откройте окно аргументов в поле «Число разрядов».
  • Укажите разрядность, до которой нужно сократить дробь.

Теперь вы знаете, как сделать, чтобы Excel не округлял, какие методы для этого существуют, и как вернуть нужные настройки обратно.

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.
Читайте так же:
Не работает микрофон в наушниках на Windows 10

Округление в Excel

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

функция округл в Excel примеры

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Функция Округлвверх в Excel примеры

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Функция Округлвниз в Excel примеры

Еще больше полезных приемов в работе со списками данных и функциями в Excel вы узнаете в практическом курсе “От новичка до мастера Excel“. Успей зарегистрироваться по ссылке!

голоса
Рейтинг статьи
Ссылка на основную публикацию